Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! на языке паскаль

дара333 дара333    3   16.09.2019 15:30    1

Ответы
yanchikkatsia yanchikkatsia  07.10.2020 19:59
Var
a,b,c:real;
begin
Readln(a,b,c);
if a > c then a:= a/2;
if c > b then c:= c-b;
Writeln(a, ' ', b, ' ', c);
end.

Пример:
4 2 3
2 2 1
ПОКАЗАТЬ ОТВЕТЫ
57494967468746 57494967468746  07.10.2020 19:59
Var
x,y,z:real;
begin
write('Введите 1 число: ');
readln(x);
write('Введите 2 число: ');
readln(y);
write('Введите 3 число: ');
readln(z);
if x>z then x:=x/2;
if z>y then z:=z-y;
writeln('1 число: ',x);
writeln('2 число: ',y);
writeln('3 число: ',z);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика