Составить программу для ввода с клавиатуры некоторого массива чисел типа integer или real с правильным диалогом программы и пользователя. на всякий случай: имена переменных в программах у обучающихся совпадать не должны. также следует обеспечить диалог с пользователем. в программе обязательны ! комментарий по ходу выполнения программы давать вразумительный

Bublick08 Bublick08    3   24.09.2019 09:10    1

Ответы
PonchikPonchikovuy PonchikPonchikovuy  08.10.2020 14:44
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество элементов в массиве:');
  var a:=ReadArrReal('Вводите элементы массива через пробел или Enter',n);
  Writeln('Ввод завершен')
end.

Пример
Количество элементов в массиве: 5
Вводите элементы массива через пробел или Enter 3.5 7 -2.9 0.4 11.345
Ввод завершен
ПОКАЗАТЬ ОТВЕТЫ
maksim20081986 maksim20081986  08.10.2020 14:44
Язык не указан, так что напишу на паскале ABC.

const
  maxn = 100;

type
  myarr = array [1..maxn] of integer;

var
  a: myarr;
  n, i: integer;

begin
  writeln('Введите размер массива:');
  readln(n);
  writeln('Введите массив:');
  for i := 1 to n do
    read(a[i]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика