Напишите программу на языке pascal для следующей : определить число n, при котором сумма квадратов ряда чисел 1, 2, …, n не превысит некоторого целого числа k, т.е. число k вводится с клавиатуры

Dianaspbrf Dianaspbrf    2   24.09.2019 09:10    2

Ответы
Farman2001 Farman2001  08.10.2020 14:43
//программа определит максимальное n
program qwerty;
var a, k, sum:integer;
begin
readln(k);
a:=1;
while((sum+a*a)<=k) do begin
sum:=sum+a*a;
a:=a+1;
end;
writeln(a-1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика