Напишите программу, проверит является ли билетик счастливым. Номер билета семизничный Счастливым считается такой билет сумма цифр которого на четных позициях равна сумме цифр на нечетных
позициях. Например, 1234167

mehimehi225 mehimehi225    2   22.05.2021 12:26    0

Ответы
солнышко279 солнышко279  21.06.2021 12:28

s = str(input())

sum1 = 0

sum2 = 0

for i in range(0, 7, 2):

   sum1 += int(s[i])

for i in range(1, 7, 2):

   sum2 += int(s[i])

if sum1 == sum2:

   print("YES")

else:

   print("NO")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика