Составить блок-схему и написать программу на языке C для задачи: Найти сумму делителей натурального числа.

Подходит ли прикрепленная блок схема к этому заданию?

include
int sum( int n)
{
int summa = 0;
for( int i = 1; i < n; i++ )
if(n % i == 0 ) summa += i;
return summa;
}
int main ()
{printf("vvedite N="); scanf("%d",&n);
printf("Summa deliteley chisla %d = %d", n, sum(n));
}

нужно подправить код


Составить блок-схему и написать программу на языке C для задачи: Найти сумму делителей натурального

didisa0282 didisa0282    1   30.01.2022 09:14    11

Другие вопросы по теме Информатика