Напишите программу, позволяющую определить, входит ли заданная цифра в некоторое целое неотрицательное число

ТимурМеирханов ТимурМеирханов    1   28.11.2019 15:18    17

Ответы
ExDragon ExDragon  10.10.2020 16:49

var

n, r: integer;

begin

write('n = ');

readln(n);

writeln;

while (n > 0) and (r < > 2) do

begin

r : = n mod 10; { < == последняя цифра числа }

n : = n div 10 { < == удаляем последнюю цифру }

end;

writeln(r = 2); { < -- выводим значение выражения (r=2) }

readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика