Дан одномерный массив из n вещественных элементов.составить программу вычисления их среднего нужно на завтра,

Garri1209 Garri1209    2   01.04.2019 10:10    3

Ответы
божена2006 божена2006  07.06.2020 04:59

program 1; 
uses crt; 
cоnst n=10; 
var arr:array[1..N] of real; 
sum:real; 
i:integer; 
Begin clrscr; 
writeln('Please entel array'); 
for i:=1 to N do 
read(arr); 
sum:=0; 
for i:=1 to N do 
sum:=sum+arr; 
writeln(); 
writeln("result=",sum/N); 
readln; 
End.

ПОКАЗАТЬ ОТВЕТЫ
koli17 koli17  07.06.2020 04:59

const N={задаём};

var a:array[1..N] of real; sr,summ:real; i:integer;

begin

  for i:=1 to N do

     read(a[i]);

  for i:=1 to N do

   summ:=summ+a[i];

    sr:=summ/N;

    write(sr);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика