Написать программу нахождения минимального из 4 чисел используя процедуру нахождения наименьшего из двух чисел.

evgeha19821 evgeha19821    1   26.01.2021 23:12    2

Ответы
danmirlav danmirlav  26.01.2021 23:20

У вас там преподаватели вообще не запариваются с написанием домашки? Второй раз за день одно задание.

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

 if a<b then min:=a else min:=b;

end;

begin

 writeln('Введите 4 числа ');

 readln(x,y,z,n);

 Minim(x,y,min1);

 Minim(z,n,min2);

 Minim(min1,min2,x); //x нам уже не нужен. А чем объявлять еще одну переменную, давай использовать ненужную

 writeln('Минимальное число из четырех =',x);

end.

ПОКАЗАТЬ ОТВЕТЫ
dega7981 dega7981  26.01.2021 23:20

var x,y,z,n,min1,min2: integer;

procedure Minim(a,b: integer; var min: integer);

begin

if a<b then min:=a else min:=b;

end;

begin

writeln('Введите 4 числа ');

readln(x,y,z,n);

Minim(x,y,min1);

Minim(z,n,min2);

Minim(min1,min2,x);

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика