tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу на языке
Напишите программу на языке паскаль для решения дано четырёхзначное число х. найти: a. число десятков в нем; b. число единиц в нем; c. число сотен в нем; d. число тысяч в нем; e. сумму его цифр; f. произведение его цифр.
Dasha5746
1 20.09.2019 09:40
7
Ответы
ksenijasadovsa13
16.08.2020 19:20
Uses crt;
var input, betw:integer;
begin
readln(input);
betw := input;
betw := betw div 10;
betw := betw div 10;
betw := betw div 10;
writeln('Тысяч = ', betw);
betw := input;
betw := betw div 10;
betw := betw div 10;
betw := betw mod 10;
writeln('Сотен = ', betw);
betw := input;
betw := betw div 10;
betw := betw mod 10;
writeln('Десятков = ', betw);
betw := input;
betw := betw mod 10;
writeln('Единиц = ', betw); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Møŝķá56
04.05.2020 10:58
2. На перший поверх будинку, у якому міститься велика фірма, спустився порожній ліфт. Вантажопідйомність ліфта – 500кг. Люди заходять до ліфта по черзі. Заповніть блок-схему...
kitecat12
25.07.2019 17:20
Заполнить одномерный массив числами целыми (от 40, до 400) с функции случайных чисел. найти сумму элементов, которые делятся на 5 pascal...
Лилия515
06.09.2019 21:20
Информационное сообщение объемом 625 бит содержит 125 символов.какова мощность алфавита?...
сергей940
06.09.2019 21:20
Алгоритм нахождения площади круга и треугольника...
marina2770
06.09.2019 21:20
Переведите в биты: 2кб 16байт 1мб 2^3байт (это степень) 18кб...
alisherqwd
25.07.2019 20:10
Фирма выпускает два типа почвы для комнатных и для рассады. производство требует двух компонентов а и в. максимальные суточные запасы этих компонентов на складе 6 и 8 соответственно....
Murew
25.07.2019 20:10
Дан двумерный массив a размерностью м*n. отсортировать все строки по возрастанию значений элементов....
Nodar2004
16.04.2020 10:50
Поверх льнян...рубашки надевали коротк и узк мехов кафтан...
Kirilloo673
16.04.2020 10:50
Обьем сочинения не менее 70 слов.Структуру сочинения 1абзац – определение понятия благодарности.2абзац – привести пример из текста.3абзац – привести пример из художественной...
renata59
16.04.2020 10:50
Черты характера главного героя рассказа Уроки французского Цитатные примеры : 1.Нравственная стойкость (преодоление голода, упорство в учёбе и в играх и др.) 2.Чувство собственного...
Популярные вопросы
10 информатика1. запишите, какие команды вы включили бы в состав команд процессора,...
3
Обоснуй или опровергни высказывание украинского философа 18 в. григория сковороды:...
2
Перевести на латинский язык,этот текст,)...
2
Запишите реакцию обмена в молекуле и hcl+naoh- k2co3+h2so4 - заранее...
1
Спростити вираз, з розв язком на листочку...
1
Катет прямокутника дорівнює 6 см, а медіана проведено до нього. знайти гіпотенузу...
3
Какую массу сао можно получить при прокаливании сасо3 массой 500 г, если...
1
Внука майкла зовут микки; микки и мико родные; у мегели пока еще нет детей;...
3
Раскройте особенности дошкольного в странах европы (испания,болгария) и сравните...
3
Решите уравнение: 3х-2=ах относительно неизвестного х - выясните при каких...
2
var input, betw:integer;
begin
readln(input);
betw := input;
betw := betw div 10;
betw := betw div 10;
betw := betw div 10;
writeln('Тысяч = ', betw);
betw := input;
betw := betw div 10;
betw := betw div 10;
betw := betw mod 10;
writeln('Сотен = ', betw);
betw := input;
betw := betw div 10;
betw := betw mod 10;
writeln('Десятков = ', betw);
betw := input;
betw := betw mod 10;
writeln('Единиц = ', betw); end.