tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан двумерный массив
Дан двумерный массив a размерностью м*n. отсортировать все строки по возрастанию значений элементов.
Murew
3 25.07.2019 20:10
3
Ответы
mirnayanatulya
13.08.2020 22:20
Const
M = 10; // Количество строк
N = 10; // Количество столбцов
var
arr: array [1..M, 1..N] of integer;
i,j,z,min,temp : integer;
begin
for j := 1 to M do
for i := 1 to N do
arr[j, i] := random(99);
writeln('Исходный массив:');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
for j := 1 to M do
begin
for i := 1 to N - 1 do
begin
min := i;
for z := i + 1 to N do
if arr[j, z] < arr[j, min] then
min := z;
temp := arr[j, min];
arr[j, min] := arr[j, i];
arr[j, i] := temp;
end;
end;
writeln;
writeln('Отсортированный массив');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Zauchka17
09.12.2019 00:21
Краткий конспект операционная система. графический интерфейс...
badangel888
09.12.2019 00:16
Всем , сильно и нужна ваша ! 1.дано слово: строка. написать программу, заменяющую букву т на к 2.написать программу, которая проверяет, является ли данный текст записью...
pushkinaksenya
08.12.2019 23:52
Записать внутреннее представление десятичного числа 789,254, ...
Соня12811
08.12.2019 23:52
на с++ необходимо написать такое : из массива 5*5 составить массив 2*2, в котором будут четыре максимальных элемента исходной...
Zaika14102001
08.12.2019 23:50
70 ! на с++ необходимо написать такое : из массива 5*5 составить массив 2*2, в котором будут четыре максимальных элемента исходной...
Екатерина20876
14.09.2020 01:24
Представь число −362(10) в 2 -байтовом формате: A 101101010 B 1111111010010101 C 1111111010010110 D 0000000101101010...
artiom247
13.09.2020 19:18
Какой тип ссылок необходим для использования в расчетных формулах переменных величин?...
BazikPro
26.05.2019 04:50
Решить )с решение m+9l-k-2t+p m=33257(10) l=97a(16) t=76705(8) p=76705(8) k=1 0000 0000 0011 0101(2)...
niga2345
24.04.2020 15:57
20 секунд записи цифрового стерео-аудиофайла занимает на диске 4 Мб, глубина звука – 20 бит. С какой частотой дискретизации записан звук?...
slavikabdulla
31.07.2019 20:10
Внесите изменения в программу, чтобы переменная age имела значение 15. public class solution { public static void main(string[] args) { string name = amigo ; int...
Популярные вопросы
1. what funny advice! a ) a b) the c) - 2. look at stars ! they...
2
5примеров названий растровых графических редакторов...
2
Буду дайте заголовок к биографической статье о гейне...
3
Мёртвые души 1)развязка,кульминация ,развязка 2) создания кратко...
3
По глобусу или на карте полушарий определите расстояние между...
3
Краткий конспект по 1 и 2 главе романа герой нашего времени...
3
6. заполните пропуски sinse или for. mike left school when he...
3
Сравните площадь россии с площадью других государств мира , сделайте...
2
Сдревних времен был известен пушной промысел. как ты думаешь почему...
3
Випишіть речення в такій послідовності: двоскладні, односкладні...
1
M = 10; // Количество строк
N = 10; // Количество столбцов
var
arr: array [1..M, 1..N] of integer;
i,j,z,min,temp : integer;
begin
for j := 1 to M do
for i := 1 to N do
arr[j, i] := random(99);
writeln('Исходный массив:');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
for j := 1 to M do
begin
for i := 1 to N - 1 do
begin
min := i;
for z := i + 1 to N do
if arr[j, z] < arr[j, min] then
min := z;
temp := arr[j, min];
arr[j, min] := arr[j, i];
arr[j, i] := temp;
end;
end;
writeln;
writeln('Отсортированный массив');
for j := 1 to M do
begin
for i := 1 to N do
write(arr[j, i] : 2, ' ');
writeln;
end;
end.