tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Заполнить одномерный массив числами
Заполнить одномерный массив числами целыми (от 40, до 400) с функции случайных чисел. найти сумму элементов, которые делятся на 5 pascal
kitecat12
2 25.07.2019 17:20
1
Ответы
guara3
03.10.2020 12:46
Const n=10;
var a:array[1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(361)+40;
write(a[i]:5);
end;
writeln;
s:=0;
for i:=1 to n do
if a[i] mod 5 = 0 then s:=s+a[i];
writeln('s = ',s);
end.
Пример:
346 213 87 382 165 184 278 261 124 233
s = 165
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
molonchik
19.12.2020 14:30
дано трехзначное число кратна ли сумма его цифр шести и не нужно писать что это число 222 если не знаете не отвечайте, мне нужен тот чел который реально понимает информатику (кто...
zlatovlaska
19.12.2020 14:29
Решите задачу на Очень От души...
superogurec002
19.12.2020 14:29
Запиши число 14662 в развёрнутом виде, начиная со старшего разряда....
LEVATOR
19.12.2020 14:28
Нужно нарисовать схему на этот код в С++ #include #include using namespace std; int main() { setlocale(LC_CTYPE, ); cout n; if (n 2) { cout введено слишком маленькое число\n ;...
Lidiiiiiiiiiia
19.12.2020 14:28
Skеtch Up программа көмегімен сфера курылган.курылган сфераны рет мен орналастыру ...
аор8
19.12.2020 14:27
1) подсчитать произведение отдельных элементов в каждой строке матрица размером 5х5 2) подсчитать количество нечётных отрицательных элементов в матрице размером 5х5 3) найти наибольший...
НекоТян124
19.12.2020 14:27
с заданием Конвертер валют (Python) Пользователь вводит количество рублей. В результате выводятся количество рублей в разных валютах. Отношения валют хранятся в переменных, т.е....
dasha5334678
14.09.2019 17:10
Cоставьте программу на языкe с++ реализовать эпизод применения компьютера в книжном магазине: компьютер запрашивает стоимость книг и сумму, внесенную покупателем, если сдача не...
Yuliy5321
14.09.2019 15:46
Какую текстовую информацию можно оформить в табличной форме, а какую нецелесообрано? 5 примеров...
thewinterstale
16.10.2019 10:14
Составить программу определяющую является ли число , введённое с клавиатуры отрицательным ?...
Популярные вопросы
Виконати тестові завдання. 1.Поетові байдуже, де він: а)житиме; б)зможе оселитися;...
2
Умножение рациональных чисел. Урок 3 Реши уравнение.|х : 5 =8/9 *| 4/5 - 7/8|...
2
Определи правильную последовательность внутреннего строения стебля. Сердцевина...
2
Решить до завтра или сегодня заранее...
2
Предложение к слову водный безводный...
3
Яку кількість теплоти потрібно витратити від 50 грам пари з температурою 100°,...
3
Обьясните номера 7,8 и в части в 6 номер...
2
Найдите производную (x^2(x+1)) ...
3
1. Заполните пропуски артиклями a, an, the или отсутствие артикля You have received...
1
два прямокутних трикутники ABC і DBC, площини яких не розбігаються, мають спільний...
3
var a:array[1..n] of integer;
i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(361)+40;
write(a[i]:5);
end;
writeln;
s:=0;
for i:=1 to n do
if a[i] mod 5 = 0 then s:=s+a[i];
writeln('s = ',s);
end.
Пример:
346 213 87 382 165 184 278 261 124 233
s = 165