Напишите программу на с++, нужно. вася, петя и коля играли в теннис навылет (проигравший пропускал следующую партию, уступая свое место третьему). вася утверждает, что сыграл x партий, петя – что сыграл y партий, коля – z партий. определите, могло ли такое быть.

loginov555 loginov555    3   30.09.2019 04:50    36

Ответы
wolf13131 wolf13131  21.08.2020 18:48
Некоторые условияСкорее, главное условие - это чётность игр. Поскольку в партии играет по двое, то сумма чисел должна быть чётной. Код

#include <iostream>

using namespace std;

int main()

{

   unsigned int x, y, z;

   cin >> x >> y >> z;

   if((x + y + z) % 2 == 0){

       if((3*z + 2 >= x + y) || (3 * x + 2 >= y + z) || (3 * y + 2 >= x + z)){

           cout << "YES";

           return 0;

       }

   }

   else{

       cout << "NO";

       return 0;

   }

   return 0;

}

Проверка

2 2 2                                                                                                

YES

3 1 2                                                                                                

YES

1 1 1                                                                                                

NO

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика