)информатика ввод 10 элементов массива случайным образом из диапазона от (-50,50). посчитать кол-во отрицательных чисел. написать программу

еденорожек12 еденорожек12    3   24.07.2019 13:20    1

Ответы
иван1208 иван1208  03.10.2020 11:50
// PascalABC.NET 3.1, сборка 1211 от 31.03.2016
begin
  var a:=ArrRandom(10,-50,50); a.Println;
  Writeln('Отрицательных ',a.Where(x->x<0).Count)
end.

Тестовое решение:
37 -20 2 -13 10 9 -25 11 8 -3
Отрицательных 4
ПОКАЗАТЬ ОТВЕТЫ
GravityFalls12 GravityFalls12  03.10.2020 11:50
Var
  a: array[1..10] of integer;
  i, n: integer;

begin
  for i := 1 to 10 do
  begin
    a[i] := random(101) - 50;
    if a[i] < 0 then n := n + 1;
    write(a[i]:4);
  end;
  writeln;
  writeln('Количество отрицательных = ', n);
end.

Тестовое решение
  30   1 -23 -36  15 -40  18  38  43  47
Количество отрицательных = 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика