Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [-5,5], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет.
Пример:
Массив: -5 -6 2 3 -3 0 8 -3 0 9
Что ищем: 0
A[8] = 0

BRAJJ BRAJJ    1   27.11.2021 14:17    58

Ответы
ррррр84 ррррр84  27.11.2021 14:20

Примерно так:

program Poisk;

const

N = 10;

type

mas = array [-10..N] of integer;

var

a: mas;

x: integer;

i: integer;

begin

readln (x);

for i := 1 to x do

a[i] := random (10);

for i := 1 to x do

begin

if (a[i] = 0) then

writeln ('a',i,' := ',a[i])

else

writeln ('Такого индекса нету');

end;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика