Надо написать программу на паскале: имеется массив a из n целых чисел, массив b из m целых чисел . составить массив с из n+m целых чисел , таких, что вначале идут числа массива a , а затем числа массива b.

xXEliteXx xXEliteXx    3   14.07.2019 14:20    3

Ответы
Viktoriya3124 Viktoriya3124  03.10.2020 04:05
Program test;
var  a: array of integer;  b: array of integer;  c: array of integer;  aa, bb, cc: integer;
begin  writeln('Введите размер массива a');  readln(aa);  writeln('Введите размер массива b');  readln(bb);  a := new integer[aa];  b := new integer[bb];  c := new integer[aa + bb];  cc := 0;  aa := 0;  bb := 0;  writeln('Заполнение массива a');  while(aa < Length(a)) do   begin    readln(a[aa]);    aa := aa + 1;  end;  writeln('Заполнение массива b');  while(bb < Length(b)) do   begin    readln(b[bb]);    bb := bb + 1;  end;  while(cc < Length(c)) do   begin    if(cc < Length(a)) then begin      c[cc] := a[cc]    end else begin      c[cc] := b[cc - Length(a)];    end;    cc := cc + 1;  end;  writeln('Полученный массив');  cc:=0;  while(cc < Length(c)) do   begin    writeln(c[cc]);    cc:=cc+1;  end;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика