Напишите программу, которая в последоваnельности натуральных чисел определяет максимальное число, кратное 5. программа получает на вход количество чисел в последовательности, а затем сами числа.в последовательности всегда имеется число, кратное 5. ко личе ство чисел не пре вы ша ет 1000. введённые числа не пре вы ша ют 30 000. пграмма должна вывести одно число — максимальное число, кратное 5.

Kymir1 Kymir1    1   27.08.2019 06:20    5

Ответы
ivan200302 ivan200302  20.08.2020 16:10

Program kratnoe;

var N,i,a,max: integer;

begin

writeln('Введите количество чисел:'); Readln(N);

max:=0;

For i:=1 to N do

begin

write('Введите число:'); readln(a);

if a mod 5 = 0 then

if a>max then max:=a;

end;

writeln('ответ:',max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика