tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу которая считает
Напишите программу которая считает произведение цифр введенного натурального числа..
2007arttt
2 23.07.2019 10:40
3
Ответы
Kasseno4ka
25.08.2020 12:59
Var
n, p: integer;
begin
write('Число: ');
readln(n);
p := 1;
while n > 0 do
begin
p := p * (n mod 10);
n := n div 10
end;
writeln('Произведение цифр = ', p);
end.
Тест №1
Число: 54321
Произведение цифр = 120
Тест №2
Число: 54320
Произведение цифр = 0
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
chardonayyyyyoyl8au
22.12.2021 16:12
, ОЧЕНЬ , УМОЛЯЮ Дан одномерный целочисленный массив Z[3..17], заданный случайными числами на промежутке (-25; 25). Найдите среднее арифметическое элементов массива....
lsodh
28.12.2019 14:27
Кумир. не могу понять, почему выдает ошибку....
boha3
28.12.2019 16:17
Условиедано четыре числа. необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно.формат входных данныхс клавиатуры вводятся...
ДжузоСузуя13
28.12.2019 16:16
1. составьте программу, увеличивающую введенное число на 1, если оно больше или равно100 и уменьшающее число на 1 в противном случае. 2. составить программу, запрашивающую...
1аук7
28.12.2019 15:54
Как сделать текст вот таким (желательно на python или сайт какой нибуть, сам я это не буду писать) - п пр при прив при пр п напишите код !...
Лилия200000
28.12.2019 15:33
Решить на языке python. (1 без блок схемы)...
mariarura
28.12.2019 18:04
Дано четыре числа. необходимо найти произведение чисел, кратных 13.формат входных данныхс клавиатуры вводятся 4 целых числа, по модулю не превосходящих 100.формат...
wiiiikkkkaaa
28.12.2019 17:57
Python python python python python python python напишіть програму, яка реалізує популярну гру – black jack. згідно з правилами, колода перемішується випадковим чином,...
polina030502
28.12.2019 17:55
Дано шесть чисел. необходимо определить сумму тех чисел, которые кратны 2, но не кратны 4. формат входных данных с клавиатуры вводятся 6 целых чисел. все числа по...
Anonumus671
28.12.2019 17:37
На паскале 1. составьте программу, увеличивающую введенное число на 1, если оно больше или равно100 и уменьшающее число на 1 в противном случае. 2. составить программу,...
Популярные вопросы
5.86 Read the email and answer the questions. 21 What is the email...
1
Найдите первый член и знаменатель геометрической прогрессии (...
2
Δ — равнобедренный, =, ∡+∡= 160°. Определи величину∡. 1. Назови...
2
3. Какое название носил остров, на котором были погребены тела...
1
з 3 моль водню одержали 50 грамів води. Обчисліть відносний вихід...
3
Розставити розділові знаки, підкреслити ВСІ члени речення, намалювати...
2
Не как не могу определиться с подарком на новый год. Варианты:...
3
pешить пошагово, с рисунком. В основе треугольной призмы равнобедренный...
3
Значення творчості Каменяра....
3
Відображення особистого життя у творчості І.Франка ( твори та...
3
n, p: integer;
begin
write('Число: ');
readln(n);
p := 1;
while n > 0 do
begin
p := p * (n mod 10);
n := n div 10
end;
writeln('Произведение цифр = ', p);
end.
Тест №1
Число: 54321
Произведение цифр = 120
Тест №2
Число: 54320
Произведение цифр = 0