На паскале
1. составьте программу, увеличивающую введенное число на 1, если
оно больше или равно100 и уменьшающее число на 1 в противном
случае.
2. составить программу, запрашивающую возраст и отвечающую
« друг» если возраст введен меньше 16 лет и отвечающую «не
знаю тебя» в противном случае.
3. составить программу - отзывающуюся только на имя «петя».

Anonumus671 Anonumus671    1   28.12.2019 17:37    4

Ответы

1) program n1;

var a:integer;

begin

writeln ('Введите натуральное число:');

readln (a);

if a>=100 then

writeln (a+1)

else writeln (a-1)

end.

2) program n2;

var a:integer;

begin

writeln ('Сколько тебе лет?');

readln (a);

if a<=16 then

writeln ('Привет друг')

else writeln ('Не знаю тебя')

end.

3) program n3;

var a:string;

begin

writeln ('Введи имя');

readln (a);

if a='Петя' then

writeln ('Привет друг')

else writeln ('Не знаю тебя')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика