Напишите программу, которая проверяет правильность имени переменной в языке паскаль. имя может содержать только латинские буквы (заглавные и строчные), цифры и знак подчёркивания, но не может начинаться с цифры. входные данные на вход программы подаётся символьная строка, содержащая имя переменной. выходные данные программа должна вывести ответ 'yes', если строка представляет собой правильное имя переменной в языке паскаль, и 'no', если имя ошибочно. примеры входные данные abc123 выходные данные yes входные данные abc[a! выходные данные no pascal abc 1.8 с использованием множеств

скули скули    3   23.08.2019 14:50    26

Ответы
dima1025 dima1025  05.10.2020 14:47
Var s: string;
    i: integer;
    good: boolean;
begin
readln(s);

good := True;
if (s[1] in ['0'..'9']) then
  good := False
else
begin
  for i := 1 to length(s) do
    if not ((s[i] in ['a'..'z']) or (s[i] in ['A'..'Z']) or (s[i] in ['0'..'9']) or (s[i] = '_')) then
      good := False;
end;

if (good) then
  writeln('YES')
else
  writeln('NO');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика