Напишите программу, которая в последоательности натуральных чисел оределяет сумму всех чисел, кратных 6 и оканчивающтхся на 2. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность ). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел кратных 6 и оканчивающихся на 2. вводные данные 12, 24, 22, 72, 11, 0. выходные данные 84 !

evgeniaberezka evgeniaberezka    1   29.08.2019 13:50    3

Ответы
Lepninanastia Lepninanastia  26.08.2020 11:57
Var A:byte;
    S:integer;
Begin
Repeat
Read(A);
if (A mod 6 = 0)and(A mod 10 = 2) then S:=S+A;
Until A = 0;
Write(S);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика