Напишите программу, которая проверяет, не ли суммирование двух заданных целых чисел(определенного типа) к переполнению.

khabayevayas khabayevayas    1   08.06.2019 04:40    1

Ответы
Medewjik Medewjik  07.07.2020 14:22
Const
  low=-32768;
  high=32767;
Var i, j :integer;
begin
  readln(i,j);
  if sign(i)*sign(j)<0 then writeln('Сложение допустимо, результат ',i+j)
  else
    if i<0 then
      if j<low-i then writeln('Сложение недопустимо: возникнет переполнение')
      else writeln('Сложение допустимо, результат ',i+j)
    else
      if j>high-i then writeln('Сложение недопустимо: возникнет переполнение')
      else writeln('Сложение допустимо, результат ',i+j)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика