Написать код программы , который в последовательности натуральных чисел определяет максимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Заразный1 Заразный1    2   11.05.2020 20:49    4

Ответы
КсенияА2006 КсенияА2006  14.10.2020 13:33

program z1;

var a, i, n, max: integer;

begin

max:=0;

write ('Введите количество чисел в последовательности ');

readln (n);

for i:=1 to n do

begin

write ('Введите натуральное число ');

readln (a);

if a > max then max:=a

end;

writeln('Максимальное число в последовательности ',max)

end.

Объяснение:

Т.к. программа будет получать на вход натуральные числа, то первоначальным значением для переменной max можно взять 0.

Он не является натуральным числом, но все натуральные числа больше него.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика