Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическое всех чисел из отрезка [a; b], которые делятся на 3.
программа на питоне

КсЮшЕнЬкА1102 КсЮшЕнЬкА1102    1   29.07.2021 14:29    4

Ответы
Neу4 Neу4  28.08.2021 14:55

from statistics import mean

a = []

for i in range(int(input('a = ')), int(input('b = ')) + 1):

   if i % 3 == 0:

       a += [i]

print('Ср. арифм. всех чисел:', mean(a))


Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическ
ПОКАЗАТЬ ОТВЕТЫ
Хрусть Хрусть  28.08.2021 14:55

a=int(input())

b=int(input())

mas=[i for i in range(a,b+1) if i%3==0]

print(sum(mas)/len(mas))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика