Напишите программу, которая для заданного целого числа определяет:

а) является ли число четным;

б) оканчивается ли оно цифрой 5.

Для решения задачи вспомните операцию mod (остаток от деления) и составьте логические выражения для ответа на во задачи.

dani2d dani2d    1   12.04.2020 22:23    12

Ответы
margoschka02 margoschka02  13.09.2020 19:58

ответ:Ох уж и не думал что вернусь в этот язык

Объяснение:

program название;

var a;

Begin

Writeln ("Введите число:");

Readln(a);

if (a mod 2 <> 1) then Write("Число нечетно");

else write ("Число чётное");

if (a mod 5 <> 5 and a mod 10 <> 5) then write ("Число не оканчивается на 5")

else Write ("Число оканчивается на 5");

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика