tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите на паскале программу.
Напишите на паскале программу. вводятся 2 целых числа. если одно из них является квадратом другого, то вывести 1, иначе вывести 0.
anavidyan920
3 17.09.2019 21:20
7
Ответы
Alikman123
07.10.2020 22:40
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var (a,b):=ReadInteger2;
if (a*a=b) or (b*b=a) then write(1) else write(0);
end.
ПОКАЗАТЬ ОТВЕТЫ
BANDI8764886
07.10.2020 22:40
Var
a,b: integer;
begin
writeln('Введите два числа');
readln(a);
readln(b);
if (a*a=b) or (b*b=a) then
writeln('Вывод 1') else writeln('Вывод 0');
readln;
end.
{Тест}
Введите два числа
25
5
Вывод 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
VladDzundza
19.06.2019 11:40
Вкаких форматах данные могут быть представлены в электронных таблицах?...
nikitamarar2177
19.06.2019 11:40
Nучащихся получили оценки за контрольную работу. ввести оценку каждого ученика, найти средний , кол-во неудовлетворительных оценок...
ania47
19.06.2019 11:30
Сколько сидит объемом 600 мбайт потребуется для размещения информации полностью занимающей жесткий диск емкостью 40 гбайт...
МихаилШуршалов
19.06.2019 11:30
Составьте блок схему алгоритма и программу вычисления в матрице b количествах элемента меньше 5 состоящих на побочной диагонала. написать...
Shedhfjfdhcdgb4573
19.06.2019 11:30
1)введите число, если оно положительное,то увеличить его в 10 раз. , чтобы программа пошла; 3 2)вводятся оценки за зачет и контрольную работу по ,если сумма этих оценок больше...
annakislova20
19.06.2019 11:30
Красный зелёный синий перемешать какой цвет выйдет...
diasline
19.06.2019 11:30
Для хранения одного байта информации необходимо использовать...
relinaro09
19.06.2019 11:30
Написать программу для pascal : дана целочисленная матрица размерности (nxm). поменять местами строки с max и min элементами....
Георгий11712
19.06.2019 11:30
Как нарисоввть закрашенный серым цветом элипис без контура...
stolbov2005
19.06.2019 11:30
40 ! на какую тему можно сделать презентацию по информатике?...
Популярные вопросы
Подбери синонимы. салазки конь шалун торжествовать...
1
Набор в армию .это политическая, социальная или сфера?...
3
Каковы были результаты походов для фараона, командиров и рядовых воинов...
1
Решить систему: log4(x^3+y^3)=2 4log16x + log8y^3=2 в первом 4 - основание,...
2
Cкласти два речення у яких слово шапка вжито в прямому і переносному значенні...
3
Расставить знаки препинания, где нужно. объяснить их постановку или отсутствие....
3
Поезд длиной 240 метров двигаясь равномерно выезжает на мост .с этого момента...
2
Сколько страниц текста может записано на гибком диске обьема 720 кбайт? при...
2
Всосуд цилиндрической формы налили воду до уровня 80см какого уровня достигает...
3
Как менялось отношение человека к природе в ходе...
3
//Версия 3.3, сборка 1627
begin
var (a,b):=ReadInteger2;
if (a*a=b) or (b*b=a) then write(1) else write(0);
end.
a,b: integer;
begin
writeln('Введите два числа');
readln(a);
readln(b);
if (a*a=b) or (b*b=a) then
writeln('Вывод 1') else writeln('Вывод 0');
readln;
end.
{Тест}
Введите два числа
25
5
Вывод 1