Написать программу для "pascal": дана целочисленная матрица размерности (nxm). поменять местами строки с max и min элементами.

relinaro09 relinaro09    1   19.06.2019 11:30    3

Ответы
evelinkazelenyak evelinkazelenyak  02.10.2020 05:21
Program n1;
const maxm = 50;     
         maxn = 50;
var a:array[1..maxm,1..maxn] of integer;   
      min,max,i,j,n,m,x,maxi,mini:integer;
begin
write('Введите размеры матрицы (N*M): ');
readln(n,m);
writeln('Введите матрицу из ',n,' строк и ',m,' столбцов:');
min:=maxint; max:=-maxint-1;
for i:=1 to n do 
 for j:=1 to m do   
  begin   
   read(a[i,j]);
   if a[i,j]>max then begin max:=a[i,j]; maxi:=i; end;
   if a[i,j]<min then begin min:=a[i,j]; mini:=i; end;   
  end;

for j:=1 to m do 
begin 
 x:=a[maxi,j]; a[maxi,j]:=a[mini,j]; a[mini,j]:=x; 
end;

writeln('Матрица после преобразования:');
for i:=1 to n do 
begin 
 for j:=1 to m do 
  write(a[i,j],' '); 
 writeln; 
end;

end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика