Написать программу вычисления произведений в паскаль 2*4*6**(2n). решить

Shatunova1976 Shatunova1976    1   20.05.2019 10:20    3

Ответы

var
N, Y, I: Integer;
begin
  ReadLn(N); Y := 1; I := 0;
  repeat
    Inc(I);
    Y := Y * 2 * I;
  until I = N;
  WriteLn(Y);
  ReadLn;
end.

ПОКАЗАТЬ ОТВЕТЫ
jihope69 jihope69  13.06.2020 19:07

через рекурсию

 

var

function Product(N: Integer): Integer;

begin

if N = 1then

begin

Product := 2;

Exit;

end;

Product := 2 * N * Product(N - 1);

end;

 

 

var

N: Integer;

begin

ReadLn(N);

WriteLn(Product(N));

ReadLn;

end.

 

без рекурсии

 

N, Y, I: Integer;

 

begin

ReadLn(N); Y := 1; I := 0;

repeat

Inc(I);

Y := Y * 2 * I;

until I = N;

WriteLn(Y);

ReadLn;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика