Написать программу : даны 3 переменные. поменять значения переменных по следующей схеме: a=c, b=a, c=b. , , в программе pascalabc, информатика

LOSS903903 LOSS903903    3   25.08.2019 01:50    2

Ответы
Sashaklapp Sashaklapp  05.10.2020 17:48
Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
A:=C;
B:=A;
C:=B;
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.

Если имеется ввиду, поменять местами переменные в заданном порядке, то вот:

Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
Swap(A,C);
Swap(B,A);
Swap(C,B);
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика