Написать программу в паскале. ввести с клавиатуры 6 произвольных чисел. вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5.( остаток на деление на 10 равен 5).

Tashkentskiy Tashkentskiy    1   08.09.2019 14:10    26

Ответы
Viktoria11112222000 Viktoria11112222000  07.10.2020 01:02
Var i, x, count: integer;
    sum: real;

begin
    sum := 0;
    count := 0;
    for i := 1 to 6 do
        begin;
        writeln('Введите число');
        readln(x);
        if (x mod 4 = 0) or (x mod 10 = 5) then
            begin;
            sum := sum + x;
            count := count + 1;
            end;
        end;
    writeln(sum/count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика