Написать программу в паскале.предложение состоит из слов, между словами один пробел, а после последнего слова точка. найти длину самого длинного слова

LB27 LB27    1   09.06.2019 04:50    1

Ответы
balashik8379 balashik8379  08.07.2020 01:43
var
  x: array of string;
  y: string;

begin
  //readln(y);
  y := 'Привет мой дорогой и прекрасный умопомрач мир';
  x := y.Remove(y.Length - 1).Split(' ');
  y := x[0];
  foreach w: string in x do
    if (y.Length <= w.Length) then
      y := w;
  writeln(y.Length);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика