Написать программу в паскале "дано целое число n (> 0). найти наибольшее целое число к, квадрат которого не превосходит n : k^2 < = n. функцию извлечения квадратного корня не использовать. " (используя оператор while) ,

Maks2801 Maks2801    2   29.06.2019 04:40    1

Ответы
VovaMel2017 VovaMel2017  23.07.2020 08:28
Var N,k:integer;
begin
  writeln('введите N');
  readln(N); K:=n div 2;
  while k*k>N do
    k:=k-1;
  writeln(k);
end.
{Возможны и другие варианты}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика