Составить программу вычисления функции на языке PASCAL(номер 1 и 3)


Составить программу вычисления функции на языке PASCAL(номер 1 и 3)

dominika6 dominika6    1   23.06.2020 00:46    12

Ответы

1.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<=-4 then  

   y:=x*x*x-2;  

 if 6<=x then  

   y:=40-x;  

 if (-4<x) and (x<6) then  

   y:=x*x;  

 writeln('y ',y:1:3)  

end.

3.

program prog;  

var  

  x,y:real;  

begin  

 writeln('x=?');  

 readln(x);  

 if x<1 then  

   y:=2*x-17;  

 if (1<=x) and (x<=5) then  

   y:=exp(ln(x)*7);  

 if 5<x then  

   y:=x*ln(x);  

 writeln('y ',y:1:3)  

end.

exp(ln(x)*n)

,где n - степень , x - выражение.

(используется во втором упражнение которое я решил, согласитесь лучше будет выглядеть чём х*х*х*х*х*х*х)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика