tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в c++ дан
Написать программу в c++ дан одномерный массив x из n элементов. найти порядковый номер первого по счёту положительного элемента с чётным порядковым номером. все отрицательные элементы после него переписать в массив y.
oli21
2 29.05.2019 02:40
1
Ответы
Melisaaaa
27.06.2020 01:43
#include
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
danypapajoy8eeo
02.10.2021 15:10
Дан массив b[20] определить является ли сумма элементов больше 1000 блок схема...
goldwildcat1
17.05.2019 14:00
*в клетку электронной табл. можно занести: а)только формулу в)только число или текст с)только число д)число,формулу или текст е)диаграмму диопозон клетки эл. табл.-это.. а)множество...
поля875
17.05.2019 13:04
Решите и объясните почему, зависит оценка...
рашитгаиф
17.05.2019 14:00
1.: составить программу. ввести 2 числа. вычесть из большего меньшее. ещё составить блок-схему! 2. составить блок-схему и программу. условие : если хотя бы одно из трёх введенных...
titovazaiceva
19.05.2019 08:20
Составьте программу решающую следующую . известна длина окружности l. найдите площадь круга s ограниченного этой окружностью. формулы для вычисления длины окружности и площади...
Снежок74
19.05.2019 08:20
1. что такое компьютерный вирус ? а) это программы, активизация которых вызывает уничтожение программ и файлов; б) это совокупность программ, находящиеся на устройствах долговременной...
владосик13
19.05.2019 08:10
Нужно, ) 1)какой источник не относится к источнику аналоговой информации: а.фортепьяно б. скрипка в. телевизор г.телефон 9)с автовокзала в разные направления отправляются...
mashkakornilova
19.05.2019 08:10
Заполнить массив 20-ю случайными числами так, чтобы числа не повторялись....
Danika02
19.05.2019 08:10
Создать схему базы данных бд: автовокзал. цели: вычислить суммы полученной от продажи билетов, затраты на топливо для маршрутов, учёт данных о сотрудниках. (минимум 5 таблиц)...
grigoryanoksan
19.05.2019 08:10
Какое количество информации содержит восьмеричное число 55...
Популярные вопросы
Стестом ! 7. при параллельном соединении n одинаковых источников тока выполняется...
3
Утворіть відносні прикметники від поданих слів: гуаш,куля,гай,стиль,життя,корінь,річ,рій,тінь,вишня,сніг,край,сланецьплющ....
1
Y= e^3x*7*(x^2+x-1) найти экстремум...
3
Напишите мини-доклад на тему: климат земли нужно! )...
3
Нужна на грамматику яз коротко ясно nouns, verbs, reported speech, adjectives,...
2
На автобазе имеется 6 автомашин. вероятность выхода на линию каждой из...
2
Написать сочинение на тему рязанский кремль ! заранее...
1
1) какие нервные ядра расположены в ножках мозга? 2) в каком отделе мозга...
3
Поведение ленского в романе евгений онегин...
2
1. дорогосто..щие, мел..щий? почему ?...
1
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;