Написать программу с использованием подпрограммы для вычисления суммы s=1+3+5..+a"
(паскаль)

Аделя6661 Аделя6661    2   12.12.2019 21:47    5

Ответы
Gowaimargowa123 Gowaimargowa123  10.10.2020 20:19

var a:integer;

function SumN (n:integer):integer;

 var

   i,sum:integer;

begin

 i:=1;

 sum:=0;

 while i<=n do  

   begin

     sum:=sum+i;

     i:=i+2;

   end;

 if n mod 2 = 0 then sum:=sum+n;

 sumN:=sum;

end;

begin

 readln(a);

 writeln('Сумма нечётных до "a"(вкулючая в сумму "a", даже если оно чётное): ',sumN(a));

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика