Написать программу, результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) делать в turbo pascal

gggnnn gggnnn    1   19.05.2019 04:00    3

Ответы
ruevtop ruevtop  12.06.2020 08:58

function sum (n : integer) : integer;

begin

  sum := 0;

  while n > 0 do

  begin

    sum := sum + n mod 10;

    n := n div 10;

  end;

end;

 

var

  a : integer;

begin

  repeat

    writeln ('a = ');

    read (a);

  until sum (a) = 10;

  writeln ('OK');

end.

ПОКАЗАТЬ ОТВЕТЫ
iobolenkov iobolenkov  12.06.2020 08:58

var
a,a1,a2:integer;
begin
repeat
writeln (' Введите число');
readln (a);
a1:=a div 10;
a2:=a mod 10;
until (a1+a2=10);
writeln ('Верно ');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика