1)написать программу, вычисляющую сумму и среднее положительных чисел, которые вводятся с клавиатуры.вид экрана: введите числа. для завершения последовательности нажмите ноль.45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67 2)аписать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положи¬тельных чисел (длина последовательности не ограничена) . (цикл whil или repeat) определение максимального числа последовательности положительных чисел. вводите после стрелки числа. для завершения ввода введите ноль. -> 56 -> 75 -> 43 -> о максимальное число: 75.

nikomynenyzhen nikomynenyzhen    1   29.05.2019 10:40    2

Ответы
TATAP2004 TATAP2004  28.06.2020 11:44
Uses crt;
var A, B:real;
begin
writeln('45, 23, 15'); 
writeln('Сумма чисел:3');
A:=45+23+15; B:=45+23+15/3;
writeln('Сумма чисел=',A);  write('Среднее арифметическое=',B);
end.
ПОКАЗАТЬ ОТВЕТЫ
Матемитик111111111 Матемитик111111111  28.06.2020 11:44
Uses crt;
var a,b,c,k:integer;
begin
a:=0; b:=0;     k:=1;
repeatread(c);
k:=c; a:=a+c; inc(b);

until k=0;
write(a,'   ',a/(b-1));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика