Написать программу, проверяющую, является ли введённое значение факториалом некоторого числа на c#

ксюша1638 ксюша1638    2   13.06.2019 15:10    4

Ответы
79272197114 79272197114  10.07.2020 15:28
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1{   
        class Program    {       
                static void Main(string[] args) {           
                        System.Console.WriteLine("Введите число");           
                        int x = Int32.Parse(System.Console.ReadLine());           
                        int p = 1;           
                        int N = 1;           
                        if (x == 1) {               
                                System.Console.WriteLine("число {0} является фактриалом числа 0", x);                    }           
                        while (p < x)        {               
                                N = N + 1;               
                                p = p * N;         
                        }               
                        if (p == x) {                   
                                System.Console.WriteLine("число {0} является фактриалом числа {1}", x, N); 
                        } else {                   
                                System.Console.WriteLine("число {0} не является фактриалом числа", x);        }               
                        System.Console.Read();           
                }   
        }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика