Написать программу: подсчитать сумму двузначных четных чисел в диапазоне заданном пользователем. используя оператор !

987helen 987helen    1   31.08.2019 03:20    6

Ответы
arpinan arpinan  06.10.2020 06:15
Для наглядности и простоты проверки оставил вывод слагаемых:

Var S,a,b:integer;
Begin
WriteLn('Сумма нечётных двузначных чисел в [a,b]');
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
S:=0;
if a mod 2 = 0 then a:=a+1;
if a < -10 then
   Begin
   if a < -99 then a:=-99;
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>-11)or(a>b);
   a:=11;
   End;
if (b>10)and(a<100) then
   Repeat
   S:=S+a;
   WriteLn(a);
   a:=a+2;
   Until (a>99)or(a>b);
WriteLn('S = ',S)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика