Написать программу определяющую, что точка принадлежит треугольнику на языке с координаты вершин треугольника(-1; 0) (0; 1) (1; 0).

dashasm06 dashasm06    2   15.09.2019 02:10    4

Ответы
cthutq1597539 cthutq1597539  07.10.2020 15:54
#include <stdio.h>

int main() 
{
  float x,y;
  scanf("%f",&x);
  scanf("%f",&y);
  if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
  else printf("NO");
  return 0;
}

Пример:
-0.2
0.2
YES
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика