Написать программу на паскале, которая определяет количество предложений во введенном тексте.

MechtaJasnaja MechtaJasnaja    3   08.06.2019 16:20    2

Ответы
vlada2207 vlada2207  07.07.2020 19:06
в предложении "персональный компьютер фирмы Apple" имеются 4 слова, отделенные друг от друга 3 пробелами. 
Из приведенного примера видно, что количество слов в строке можно определить как сумму имеющихся в строке пробелов плюс единица. 

program help; 
Uses Crt; 
var 
i,k,ks,1:integer; с: char; s:string; 

begin 
ClrScr; 
writeln('Введите строку. Ввод завершите нажатием клавиши Enter'); 
writeln; 
readln(s) ; 
l:=length(s); 
k:=0;(k - счетчик количества пробелов} 
for i:= 1 to 1 do 
begin 
c:=s; 
if c=' ' then k:=k+l 
end; 
ks:=k+l; 
writeln; 
writeln('количество слов в данной строке составляет ',ks); 
readln 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика