Написать программу на паскале дана строка текста напечатать все слова,заканчивающиеся на "ов". если можно,то напишите программу с функции pos

fifamobile01 fifamobile01    2   20.07.2019 09:50    6

Ответы
marsimonenko2017 marsimonenko2017  03.10.2020 08:41
Считается, что слова отделяются друг от друга пробелом.
var s:string; p:integer;
begin
writeln('Введите строку:');
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
 begin
 if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));
 delete(s,1,p);
 p:=pos(' ',s);
 end;
end.

Пример:
Введите строку:
пример кров слово шов олово ров
кров
шов
ров
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика