Напишите программу поиска номера первого из двух последовательных элементов в целочисленном массиве из 30 элементов, сумма которых максимальна (если таких пар несколько, то можно выбрать любую из них).

Lina300333 Lina300333    3   22.05.2019 06:30    8

Ответы
2507901178p0bodm 2507901178p0bodm  17.06.2020 09:06

Паскаль АВС:


Program kislota;
uses crt;
const n=30;
var
  e:array[1..n] of integer;
  sum,nom,i: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Элементы массива:');
  randomize;
  nom:=0;
  for i:=1 to n do
    begin
      e[i]:=random(100)-50;
      write (e[i]:5);
    end;
  sum:=e[1]+e[2];
  for i:=1 to n-1 do
    if (e[i]+1 + e[i+1])>sum then
      begin
        sum:=e[i]+1 + e[i+1];
        nom:=i;
      end;
  writeln();
  writeln('Номер первого элемента пары с максимальной суммой: ',nom);
end.

ПОКАЗАТЬ ОТВЕТЫ
epincessg11 epincessg11  17.06.2020 09:06

var

a:array [1..30] of integer;

i,k,s:integer;

begin

randomize;

for i:=1 to 30 do begin

a[i]:=random(9)+1;

write (a[i],' ');

end;

s:=a[1]+a[2]; 

k:=1; 

for i:=2 to 29 do

if a[i]+a[i+1]>s then begin

k:=i;

s:=a[i]+a[i+1];

end; 

writeln; 

writeln ('Number: ',k);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика