Написать программу, которая вычисляет среднюю (за неделю) температуру воздуха. исходные данные должны вводиться с клавиатуры. введите температуру воздуха за неделю. понедельник -> 12 вторник -> 10 ' среда -> 16 четверг -> 18 пятница -> 17 суббота -> 16 воскресенье -> 14 средняя температура за неделю: 14.71 град.

frossbaf frossbaf    3   11.08.2019 08:50    7

Ответы
hhhttt1520 hhhttt1520  04.10.2020 10:59
На будущее: за программу никто писать не будет.
Программа, возможно, не совершенна (т.е. по-любому, можно было сделать короче), однако работает. Написана на Pascal, тестировал в веб-среде PascalABC.

var mo,tu,we,th,fr,sa,su,a: ShortInt;
var b: Real;
Begin
Write('Температура воздуха в Понедельник: ');
Readln(mo);
Write('Температура воздуха во Вторник: ');
Readln(tu);
Write('Температура воздуха в Среду: ');
Read(we);
Write('Температура воздуха в Четверг: ');
Readln(th);
Write('Температура воздуха в Пятницу: ');
Readln(fr);
Write('Температура воздуха в Субботу: ');
Readln(sa);
Write('Температура воздуха в Воскресенье: ');
Readln(su);
a:=mo+tu+we+th+fr+sa+su;
b:=a/7;
Write('Средняя температура воздуха: ',b:0:2,' градусов.');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика