Написать программу , которая вычисляет среднюю температуру воздуха за всю неделю. выясните, сколько раз в неделю температура была выше нуля.

Olya555556 Olya555556    1   20.09.2019 08:30    3

Ответы
lyudsiya1337 lyudsiya1337  08.10.2020 04:12
Program Temperatura;

Var  d, k, T: integer;  f: byte;  a: array [1..7] of integer;

Begin  f := 0;k := 0; 

Writeln('Введите температуру'); 
 for d := 1 to 7 do  Begin   
 Write(d, ' день: ');   
Readln(a[d]);     
 end; 

 for d := 1 to 7 do    if a[d] > 0            then   
 Begin     
k := k + 1;   
f := 1;   
end; 

 if f = 0        then    Writeln('Всю неделю температура была  ниже нуля.') 
else   
Writeln('Дни с температурой выше нуля - ', k); 
  
T := a[1] + a[2] + a[3] + a[4] + a[5] + a[6] + a[7]; 
WriteLn('Средняя температура за неделю:', T / 7:0:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика