Написать программу, которая вычисляет наибольший общий делитель двух целых чисел паскаль

олеся788 олеся788    2   30.05.2019 03:10    2

Ответы
moiseenkoevgeni moiseenkoevgeni  01.10.2020 14:51
Var  a, b: integer;
begin
Writeln('Введите два числа');
Readln(a, b); 
repeat 
if a > b then a := a Mod b    else
b := b Mod a; 
until (a = 0) Or (b = 0); 
writeln('НОД = ', a + b); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика