Написать программу, вычисляющую стоимость покупки с учётом скидки: куплено 4 товара, если сумма превышает 2500р, то скидка составит 5%, если превышает 1300р, то скидка составит 3%​. Нарисовать блок-схему. Язык: Паскаль​

wwwraisakravets wwwraisakravets    2   30.05.2021 14:45    11

Ответы
Daria2316 Daria2316  30.05.2021 14:50

var

summa, skidka: real;

begin

writeln('Вычисление стоимости покупки с учетом скидки.');

writeln('Введите сумму покупки: ');

readln(summa);

 if summa >= 1300 then skidka:=3

  else if summa > 2500 then skidka:=5

   else if summa < 1300 then skidka:=0;

writeln('Вам предоставлена скидка ', skidka, '%');

writeln('Сумма покупки с учетом скидки: ', (summa-(summa*skidka)/100));

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика