Написать программу. Имеется билет на автобус с 6-тизначным номером. Определить, является ли билет счастливым. Нарисовать блок-схему. Язык: Паскаль​

stanstan199 stanstan199    1   30.05.2021 14:40    1

Ответы

Программа:

var n,a1,a2,s1,s2:integer;

begin

write('n = '); readln(n);

a1:=n div 1000;

s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);

a2:=n mod 1000;

s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);

if s1=s2 then writeln('Билет счастливый')

         else writeln('Билет не счастливый')

end.

Пример:

n = 123231

Билет счастливый

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика