Написать программу, которая получает случайное целое типа int, выводит его двоичное представление на экран, выполняет преобразование в соответствии с вариантом (см. ниже), затем выводит на экран двоичное представление результата преобразования. № варианта пример 1 изменить порядок следования битов в числе на обратный 11010011  11001011 язык си

05Дарья50 05Дарья50    3   21.06.2019 09:50    7

Ответы
Dramaramanic Dramaramanic  02.10.2020 07:19
Void dvoich(int x1)   {  
srand (time(NULL));   
int i, b;       
long c = 0; 
x1 = rand();       
for(i=0;x1 > 0;i++)       {         
b = x1 % 2;      
x1 = (x1-b)/2;         
c += b * pow(10,i);     }    
printf("\nDvoichnoe chislo: %d",c);   }  
reverse(c.begin(), c.end());
printf("\nDvoichnoe obratnoe chislo: %d",c);
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика