Написать программу на языке паскаль которая вызывает из модуля подпрограмму, которая печатает содержимое непустого текстового файла по рядкам, вставляя в начало рядка слово "рядок" и номер этого рядка(4 позиции). ​

ilsafsanatullov ilsafsanatullov    3   16.12.2019 12:25    1

Ответы
Лвлчтчтчтчтчь Лвлчтчтчтчтчь  23.08.2020 11:20

interface

procedure PrintText(fn: string);

implementation  

procedure PrintText(fn: string);

begin

 var i := 1;

 foreach var s in ReadLines(fn) do

 begin

   Writeln(i:4, ' ', s);

   i += 1

 end;

end;

end.

uses nekrasov;   // вызывающая программа (другой файл)

begin

 var fn := ReadlnString('Укажи имя файла:');

 if FileExists(fn) then

   PrintText(fn)

 else

   Println('Файл не найден')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика