Написать программу которая для введённого пятизначного числа выводит количество нулей в нем

MaFizLike MaFizLike    1   13.07.2019 17:00    4

Ответы
Murmurmur29 Murmurmur29  31.07.2020 13:05
Вот уже писал.
uses crt;
var a,n,i:integer;
begin clrscr;
write('Vvedite chislo: ');
read(a); n:=0;
while a<>0 do begin
if a mod 10=0 then inc(n);
a:=a div 10;
end;
writeln('N=', n);
end.
ПОКАЗАТЬ ОТВЕТЫ
vadimviktorov06 vadimviktorov06  31.07.2020 13:05
var
   n: integer;
begin
  read(n);
  write(ord(n mod 10 = 0) + ord(n div 10 mod 10 = 0) + ord(n div 100 mod 10 = 0) + ord(n div 1000 mod 10 = 0));
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика